Skip to main content


Also see the New & Noteworthy for the latest release.

Updating:  If using a version prior to 2.0, upgrade to 2.0 before installing Mylyn 3.11.

New in Mylyn 3.11 Snapshot Builds

NOTE: Mylyn 3.10 requires Java 1.6 or later and supports Eclipse 3.8, 4.3 or 4.4. Eclipse 3.6 is now the base compilation target, so Mylyn no longer runs on Eclipse 3.5. See the download page for repository locations.

No builds have been published, yet. Stay tuned.

Back to the top