Eclipse UOMo Tutorial

Eclipse UOMo is an API for working with physical quantities and units. We are going to create a
demonstration application that provides an API to work with Newton’s Second Law of Motion:

“The acceleration of a body is directly proportional to, and in the same direction as, the net force
acting on the body, and inversely proportional to its mass.”

Otherwise written as:
F = MxA
Where:
F is Force in Newtons
M is Mass in Kilograms
A is Acceleration in Meters per second



Our example API will provide methods for computing any of the above, given the other two.

Example code for the following is available at GitHub:
https://qgithub.com/duckAsteroid/uomo-example

Getting Started - Eclipse Plugin Project...

Most of verbosity in the steps that follows are related to complexities of creating Eclipse plug-ins

rather than anything hard about using UOMo...

1. In Eclipse click the File -> New -> Project.. menu
2. Select Plug-in Project:

#@ New Project

Select a wizard

Create a Plug-in Project

I T

Wizards:

2% Java Project
# Java Project from Existing Ant BuildFile

» = General

> = Android

» = Bndtools

> = CVS

> = Eclipse Modeling Framework
b = lauA

® <Back NGNS | Concel || Finish

it Plug-in Project

Click “Next”
3. Enter a name for the plugin project (e.g. com.acme.n2l):



https://www.google.com/url?q=https%3A%2F%2Fgithub.com%2FduckAsteroid%2Fuomo-example&sa=D&sntz=1&usg=AFQjCNGn15I4sUw5-gc8-bm5mppqaoX4ww

® New Plug-in Project

Plug-in Project
Create a new plug-in project

Project name: | com.acme.nzl

B Use default location
Location: Browse...

Project Settings
B4 Create a Java project

Source folder: |_src

Output Folder: |:bir1

Target PlatForm
This plug-inis targeted to run with:

@® Eclipse version: [3.5 or greater :]

(O an OSGiframework: | Equinox =
Working sets
& Add project to working sets

Woarking sets: | Example -4 [ Select...

@ l <Back | [ Cancel | Finish

Click “Next”
4. You can now customise the plugin details as follows:



@ New Plug-in Project

Content
Enter the data required to generate the plug-in.

Properties

D: [r:om.ar:me.nzl |
Version: |-1 .0.0.qualifier |
MName: [Newtons Second Law AP |
Vendor: |-Acme Ine. 4
Execution Environment: | JavaSE-1.6 - | |[Enviconments... |
Options

[ Generate an activator, a Java class that controls the plug-in's life cycle
Activator
[ This plug-in willmake contributions to the Ul

[] Enable APl analysis

Rich Client Application
Would you like to create arich client application? (O Yes @ |@|

@ | <Back | Next> || Cancel _|H

Ensure that all checkboxes under “Options” are de-selected.
Click “Finish”
If the following dialog appears click “Yes” to open the PDE perspective:



& Open Associated Perspective?

@ This kind of project is associated with the Plug-in Development perspective.

This perspective is designed to support efficient development and
integration of plug-in projects. It adds the Plug-ins and Error Log views
which are particularly useful.

Do youwant to open this perspective now?

] Remember my decision

Mo | Yes

5. Eclipse will create your new project. Now we need to configure Eclipse so that it knows
about UOMo and where it lives to build against.
Click the menu “Window -> Preferences”

6. Navigate to the “Plug-in Development -> Target Platform” section of the preferences
dialog:



& Preferences

|' @] @ No target definiti...rently set active. - S

General Add, edit and remove target definitions. The active target

Android definition will be used as the target platform which
ARt workspace plug-ins will be compiled and tested against.

, Mew definitions are stored locally, but they can be moved
Bndtools OSGi to a project in the workspace and shared with others.
Code Recommenders

vy v v

Target definitions:
Data Management

s ' - .
Help i@ Running Platform Reload...

Install/Update l ]
Java

Maven Edit...
Mwe2
Plug-in Development
AP|Baselines Share...
AP| Errors/Warnings
APl Use 5cans
Compilers
Editors
OSGiFrameworks
Target PlatForm
Run/Debug Locations:
Team
XML

Xtend
Xeext |Restore Defaults| | Apply

Remove

4 ¥ ¥ ¥ ¥ ¥ w W%

¥y ¥ ¥ ¥ ¥

@ l Cancel | oK

Click “Add...”
7. Select “Nothing: Start with an empty target definition” in the “New target definition” dialog:



@ New Target Definition

Target Definition

Create a new target definition.

Initialize the target definition with:

@ [Nothing: Start with an empty target definition |

() Default: Default target For the running platform
() Current Target: Copy settings from the current target platform

O Template: | Base RCP (Binary On

@ <Ba

Cancel

|

Finish

Click “Next”
8. Give the new target a name, such as “UOMo”:



@ New Target Definition
Target Content >
Edit the name, description, and plug-ins contained in a target. i@
Name: IUOMo
Locations | Content | Enyironment | Arguments | Implicit Dependencies
The Following list of locations will be used to collect plug-ins For this target definition.
Edit...
Remove
Update
["] Show location content
@ | <Back | MNext > | Cancel || Finish |

Click “Add...”
9. Select “Software Site” from the plug-in source options:



( @ AddContent

Add Content

Select a source of plug-ins.

= Directory
B Installation
§* Features

“1 Software Site

Download plug-ins from a software site such as a p2 repository or update site.

@ <Back ul Cancel | Finish

Click “Next”

10. Firstly, we need to give our target definition a place to get Eclipse plug-ins from. Enter the
URL http://download.eclipse.org/releases/juno into the “Work With” field. Ensure that the
“Group by Category” field is un-checked.

Type “Eclipse Platform” into the search field:



http://www.google.com/url?q=http%3A%2F%2Fdownload.eclipse.org%2Freleases%2Fjuno&sa=D&sntz=1&usg=AFQjCNEC9pdSRZ6Y0QmRZzASB9VKI5XIzQ

@ Add Content

Add Software Site

Select content from a software site to be added to your target

Work with: |http:ﬁdownload.ectipse.orgfreleases;’juno Rl Add... |

Work with the list of software sites

\Eclipse Platform |
Name Version
i§* Eclipse PlatForm 4,2,2.M20130204-1200
§* Eclipse Platform Launcher Executables 3.6.0.v20121119-201001-7P70G2BFLWUL
i Eclipse PlatForm Plug-in Developer Resources 4,2.1.v20130118-173121-9MF7GHYdGoBE
i§* Eclipse PlatForm SDK 4,2.2.M20130204-1200
i Sapphire Eclipse PlatForm Support (Incubation) 0.5.4,201302121329

1item selected
Details
Common OS-independent base of the Eclipse platform. (Binary runtime and user documentation.)

| Properties... |

[] Group by Category [& Show only the latest version

Included Software

By default, all required software is added to the target based on its environment settings. Turning
this option off allows software to be added with missing requirements and multiple environments.
This setting applies to the entire target definition.

® Include required software

& Include source if available

& Include configure phase

@ | <Back | Next > Cancel | {*J

Select the Eclipse Platform (with out M* at the end :- as this is a milestone release)
Click “Finish”

11. Eclipse will do some loading/resolving...
Now we need to add the UOMo libraries to our target. Click “Add..” again on the target
platform editor window. The select “Software Site” again. But this time enter the URL
http://download.eclipse.org/uomo/0.6/repository/



http://www.google.com/url?q=http%3A%2F%2Fdownload.eclipse.org%2Fuomo%2F0.6%2Frepository%2F&sa=D&sntz=1&usg=AFQjCNGqWXVe1k7ntfR3uKpUXWrKPfWY-Q

@ Add Content

Add Software Site

Select content from a software site to be added to yourtarget

Work with: “http:;’/down[oad.eclipse.org/uomo/o.s/repository/ Ral Add... \

Work with the list of software sites

|

Name Version

¥ & 000 Units of Measurement (UOMo)

v i Eclipse UOMo

1item selected
Details
Eclipse UOMo

| Properties... |

& Croup by Category & Show only the latest version

Included Software

By default, all required software is added to the target based on its environment settings. Turning
this option off allows software to be added with missing requirements and multiple environments.
This setting applies to the entire target definition.

& Include required software
| Include all environments
& Include source if available

& Include configure phase

@ | <Back | Next > | Cancel |_

Select the EclipseUOMo feature.
Click “Finish”

12. Eclipse will do some more loading/resolving. You are back at the target platform
preferences page:




( & Preferences
|- @| Target Platform . -
> General Add, edit and remove target definitions. The active target
» Android definition will be used as the target platform which
b ARt workspace plug-ins will be compiled and tested against.
, Mew definitions are stored locally, but they can be moved
Bndtools OSGi to a project in the workspace and shared with others.
» Code Recommenders o
Target definitions:
» Data Management
> Help ‘8 Running PlatForm | Reload...
M/ 1K . >
> Install/Update B UOMo (Active) - /com.acme.n2l/uo
| Add...
> Java
» Maven | Edit...
> Mwe2
. | Remove
¥ Plug-in Development
AP|Baselines Share...
AP| Errors/Warnings
APl Use 5cans
Compilers
Editors
OSGiFrameworks
Target PlatForm
» Run/Debug Locations:
» Team #l http://download. eclipse.org/releases/juno
> XML %] http://download. eclipse.org/uomo/0.6/repository/
» Xtend
b Wrext |Restore Defaults | | Apply
© _ Concel | [SNOKIN

Select UOMo target and click “Apply”
13. (Optional) You can click “Share..” if you want to save this target definition as a file for use
in the future. Pick a location and a name for the target file in the window as below:



( & Share Target Definition

Share Target Definition "@'
Choose a workspace location For the target definition file i@

Enter or select the parent Folder:

|com.acme.r12l

<

= . settings
» = bin

= META-INF
P [=srC

» & n2l-api

File name: 'uomo.target

®@

Click “Finish” when you are done.
14. Click “OK” on the preferences page
15. Now you are ready to start work on our N2L plug-in.

Create a new class called NewtonsSecondLaw in the package com.acme.

Now add the following code:

package com.acme.n2l;

import org.eclipse.
import org.eclipse.
import org.eclipse.
import org.eclipse.

uomo

uomo

uomo

uomo

.units.
.units.
.units.
.units.

public class NewtonsSecondLaw

SI;
impl.quantity.AccelerationAmount;
impl.quantity.ForceAmount;
impl.quantity.MassAmount;

n2l



public static final ForceAmount calculateForce (MassAmount m, AccelerationAmount a)
{
double m kg = m.doubleValue (SI.KILOGRAM) ;
double a si = a.doubleValue (SI.METRES PER SQUARE SECOND) ;
return new ForceAmount (m_kg * a si, SI.NEWTON) ;

}

The important part of this code is the calculateForce method; it takes as parameters an
amount of mass and an amount of acceleration - and returns an amount of force. The
units of these parameters are not defined; just that they are of quanity Mass and
Acceleration respectively. So our code needs to get the absolute value of these in a
known unit for calculation - for simplicity we use the Sl units Kilogram (kg) and Metres per
second per second (m/s?).
We then simply perform the multiplication, and create a result using the Sl unit for Force -
Newtons (N).

16. Now we are ready to test out our API with a Unit test. What follows is a little long winded
thanks to how Eclipse Plug-ins do unit tests..

17. Firstly we need to create a New Fragment Project (File -> New -> Project...):

& New Project

Select a wizard

-

Create a Plug-in Fragment Project

r
L

Wizards:

b = Java

> = Maven

¥ = Plug-in Development
4§ Feature Patch
(j% Feature Project

.« Fragment Project
% Plug-in from Existing JAR Archives

4 Plug-in Project
4 Update Site Project

@ <Back Mext = Cancel Finisk




Click “Next”
18. Give the fragment the name of our main project with “.test” appended:

& New Fragment Project

Fragment Project .
Create a new fragment project

Project name: |com.acme.n2ltests

B Use default location
Location Browse...

Project Settings
B Create a Java project

Source folder: |-src

Output Folder: |-bin

Target PlatForm
This Fragment is targeted to run with:

@® Eclipse version: | 3.50r greater |

(O an OSGiframework: | Equinox
Working sets
& Add project to working sets

Warking sets: | Example - | Select...

@ | <Back JQI Cancel | Finish

Click “Next”
19. We need to give the fragment a “host” that is our com.acme.n21 plugin:



& New Fragment Project
Fragment Content .
Enter the data required to generate the fragment. @:
Properties
D: |-r:om.ar:me.r12Ltests |
Version: |-1.D.D.quaLiFier |
Mame: [NELAPITests |
Vendor: |-Ar:me Inc | * |
Execution Environment: | JavaSE-1.6 - | |[Enviconments... |
Host Plug-in
Plug-in ID: [com.acme.nzl | [;J
Minimum Version: |'1.D.I[J | |Inclusive 7 |
Maximum Version: | | | Exclusive ;|
@ | <Back MNext = | Cancel || Finish
Click “Finish”

20. Now we need to add JUnit to the fragment’s dependencies. Find and double click the
META-INF/MANIFEST.MF file to open the fragment manifest editor. Select the
“‘Dependencies” tab:



[J NewtonsSecondl aw.java i com.acme.n2ltests %

= 8

% Dependencies

Required Plug-ins 13,
Specify the list of plug-ins required For the operation of this
fragment.
Remove
Up
Down
Properties...
Total: 0
» Automated Management of Dependencies 3,

0B EO

Imported Packages

Specify packages on which this Fragment depends without
explicitly identifying their originating plug-in.

# org.unitsofmeasurement.quantity | Add...
# org.unitsofmeasurement.unit
Remove
Properties...
Total: 2

} Dependency Analysis

Overview |Dependencies|Runtime | Extensions | Extension Points| Build| MANIFEST.MF | build.properties|

Click “Add...”
21. Enter “junit” in the search field:



@ Plug-in Selection

Select a Plug-in:

|.jur1it

Matching items:

- org.junit (4.10.0.v4_10_0 v20120426-0900)

%= org.junit.source (4.10.0.v4_10_0_v20120426-0900)

org.junit

® | concel | (K

Select the org.junit plugin and click “OK”
22. Now we create a unit test class in our fragment. Find and right click on our

NewtonsSecondLaw. java file and choose “New -> Other...” from the context menu.
23. Select Java -> JUnit -> JUnit Test Case from the dialog:




-

x New

Select a wizard <
Create a JUnit Test Case

Wizards:

=2y
¥ = Java
@ Annotation
@ Class
@ Enum
@ Interface
2% Java Project
# Java Project from Existing Ant Buildfile
14 Java Working Set
# Package
&4 Source Folder
@& Typesafe Enum
» (= Java Run/Debug
¥ = JUnit
ET JUnit Test Case
EE JUnit Test Suite
> = Java Emitter Templates
> = Maven

@ <Back Ql Cancel | Finish

Click “Next”

24. Select the location for the unit test in the src folder of our test fragment. And select the
calculateForce method for testing:



& New JUnit Test Case

JUnit Test Case E

Select the name of the new JUnit test case. You have the options to specify g
the class under test and on the next page, to select methods to be tested.

) New JUnit 3test @ MNew JUnit 4 test

Source folder: |-r:om.ar:me.r12l.tests,f’src | Q

Package: |-com.acme.n2l | Browse.. |
MName: [NewtonsSeccndLawTest |
Superclass: [java.[ang.[)bject | | Browse...

Which method stubs would you like to
[ setUpBeforeClass() [ | tearDownAfterClass()
[ setUp() [] tearDown()
constructor
Do you want to add comments? (Configure templates and default value here)
] Generate comments

Class under test: [com.acme.n2L.NewtonsSecondLaw | | Browse..
@ | <Back | Next> || Cancel || Finish
Click “Finish”

25. Now we need to replace the template test code with our own. Add the following:

@Test
public void testCalculateForce() {

MassAmount m = new MassAmount (1000, SI.KILOGRAM) ;
AccelerationAmount a = new AccelerationAmount (2.5, SI.METRES PER SQUARE SECOND) ;

ForceAmount force = NewtonsSecondLaw.calculateForce(m, a);



assertEquals (2500, force.doubleValue (SI.NEWTON), 0.0001);

This method simply creates a 1000 kg mass, a 2.5 m/s2 acceleration and asks our N2L
class to calculate the force. We then assert that the calculated force is 2500 Newtons
(+/- 0.0001).

26. Save the file and Right click on it - then choose “Run As - > JUnit Plug-in Test”. The test
will run and you should see the JUnit results window appear:

v JUnit %3 B @ B~ Y =18
Finished after 0.071 seconds
Runs: 1/1 BErors: 0 B Failures: 0
¥ Kl com.acme.n2l.NewtonsSecondLawTest nner: nit 4](0.0055) = Failure Trace =

¢/ testCalculateForce (0.005s)

27. You have now completed and tested your first simple UOMo project.

OK, so what....

Ok that’s the basics out of the way now you can try a few things that demonstrate the power of
UOMo and the Units of Measurement API...

1. Try changing the units used in your unit test for mass or acceleration to units of other
quantities (i.e. seconds, metres, amperes, volts... ). You will see the compiler error
created because your unit is not the correct type... cool!

2. Same is true when we try to extract a value - change the force.doubleValue linein
the unit test to use units that are not a force... same, the compiler error because the unit
is not for a force! cool!

This is important, it protects clients of your NewtonsSecondLaw APl from making mistakes
when they create values to pass to you. They can only pass in legitimate masses or
accelerations.

As an example we can add another test method to our test case:

@Test
public void testWithOddUnits () {
We create a mass in US Pounds!

MassAmount m = new MassAmount (100, USCustomary.POUND) ;
// Now let’s create a whacky acceleration unit of our own...
@SuppressWarnings ("unchecked") // we know this creates an acceleration!
Unit<Acceleration> inch per square second =
(Unit<Acceleration>)USCustomary.INCH.divide (SI.SECOND) .divide (SI.SECOND) ;
// Note our N2L API does not know this unit at all!
AccelerationAmount a = new AccelerationAmount (100, inch per square second);
ForceAmount force = NewtonsSecondLaw.calculateForce (m, a);

// Yet our API is able to calculate the corresponding force without change



// Nice...
assertEquals (867961.6621451874, force.doubleValue (SI.NEWTON), 0.0000000001) ;

// Now let’s try to get the result in a weird unit...
Force in English engineering units

(http://en.wikipedia.org/wiki/Pound-force)

Unit<Force> poundForce = SI.NEWTON.multiply(4.448222);
// and we can now extract the result of our previous calc in that new unit!

assertEquals (3860886.16071079, force.doubleValue (poundForce), 0.0000000001) ;

// The “pound-force” is a unit for

// and British gravitational units

Nice - our API can handle weird and wonderful unit values as input and we can extract weird and
wonderful unit values as output! Sweet!




